245 lines
7.3 KiB
Nix
245 lines
7.3 KiB
Nix
# Edit this configuration file to define what should be installed on
|
||
# your system. Help is available in the configuration.nix(5) man page
|
||
# and in the NixOS manual (accessible by running ‘nixos-help’).
|
||
|
||
{ config, pkgs, ...}:
|
||
|
||
{
|
||
imports =
|
||
[ # Include the results of the hardware scan.
|
||
./hardware-configuration.nix
|
||
./gnome.nix
|
||
];
|
||
|
||
# Nix flakes support
|
||
nix.settings.experimental-features = [ "nix-command" "flakes"];
|
||
|
||
# Bootloader.
|
||
boot.loader.systemd-boot.enable = true;
|
||
boot.loader.efi.canTouchEfiVariables = true;
|
||
boot.loader.grub.configurationLimit = 10;
|
||
|
||
boot.initrd.luks.devices."luks-4060c1c6-89ef-4d17-9ef1-0d86c907a48f".device = "/dev/disk/by-uuid/4060c1c6-89ef-4d17-9ef1-0d86c907a48f";
|
||
networking.hostName = "macbook"; # Define your hostname.
|
||
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
|
||
|
||
# Clear /tmp during boot
|
||
boot.tmp.cleanOnBoot = true;
|
||
|
||
# Housekeeping: Garbage collection
|
||
nix.gc.automatic = true;
|
||
nix.optimise.automatic = true;
|
||
|
||
# Disable sudo password for the wheel group
|
||
security.sudo.wheelNeedsPassword = false;
|
||
|
||
# Configure network proxy if necessary
|
||
# networking.proxy.default = "http://user:password@proxy:port/";
|
||
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
|
||
|
||
# Enable networking
|
||
networking.networkmanager.enable = true;
|
||
|
||
# Nvidia card
|
||
# Enable OpenGL
|
||
hardware.opengl = {
|
||
enable = true;
|
||
};
|
||
|
||
# Load nvidia driver for Xorg and Wayland
|
||
services.xserver.videoDrivers = ["nvidia"];
|
||
|
||
hardware.nvidia = {
|
||
|
||
# Modesetting is required.
|
||
modesetting.enable = true;
|
||
|
||
# Nvidia power management. Experimental, and can cause sleep/suspend to fail.
|
||
# Enable this if you have graphical corruption issues or application crashes after waking
|
||
# up from sleep. This fixes it by saving the entire VRAM memory to /tmp/ instead
|
||
# of just the bare essentials.
|
||
powerManagement.enable = false;
|
||
|
||
# Fine-grained power management. Turns off GPU when not in use.
|
||
# Experimental and only works on modern Nvidia GPUs (Turing or newer).
|
||
#powerManagement.finegrained = false;
|
||
|
||
# Use the NVidia open source kernel module (not to be confused with the
|
||
# independent third-party "nouveau" open source driver).
|
||
# Support is limited to the Turing and later architectures. Full list of
|
||
# supported GPUs is at:
|
||
# https://github.com/NVIDIA/open-gpu-kernel-modules#compatible-gpus
|
||
# Only available from driver 515.43.04+
|
||
# Currently alpha-quality/buggy, so false is currently the recommended setting.
|
||
open = false;
|
||
|
||
# Enable the Nvidia settings menu,
|
||
# accessible via `nvidia-settings`.
|
||
nvidiaSettings = true;
|
||
|
||
# Optionally, you may need to select the appropriate driver version for your specific GPU.
|
||
package = config.boot.kernelPackages.nvidiaPackages.legacy_340;
|
||
};
|
||
|
||
# Set your time zone.
|
||
time.timeZone = "Asia/Taipei";
|
||
|
||
# Select internationalisation properties.
|
||
i18n.defaultLocale = "en_US.UTF-8";
|
||
|
||
i18n.extraLocaleSettings = {
|
||
LC_ADDRESS = "en_US.UTF-8";
|
||
LC_IDENTIFICATION = "en_US.UTF-8";
|
||
LC_MEASUREMENT = "en_US.UTF-8";
|
||
LC_MONETARY = "en_US.UTF-8";
|
||
LC_NAME = "en_US.UTF-8";
|
||
LC_NUMERIC = "en_US.UTF-8";
|
||
LC_PAPER = "en_US.UTF-8";
|
||
LC_TELEPHONE = "en_US.UTF-8";
|
||
LC_TIME = "en_US.UTF-8";
|
||
};
|
||
|
||
i18n.inputMethod.enabled = "fcitx5";
|
||
i18n.inputMethod.fcitx5.addons = with pkgs; [
|
||
fcitx5-chewing
|
||
fcitx5-chinese-addons
|
||
#fcitx5-mcbopomofo
|
||
#fcitx5-pinyin-zhwiki
|
||
#fcitx5-pinyin-moegirl
|
||
fcitx5-table-other
|
||
fcitx5-table-extra
|
||
fcitx5-gtk
|
||
fcitx5-rime
|
||
];
|
||
|
||
# Enable the X11 windowing system.
|
||
services.xserver.enable = true;
|
||
|
||
# Enable the GNOME Desktop Environment.
|
||
services.xserver.displayManager.gdm.enable = true;
|
||
services.xserver.desktopManager.gnome.enable = true;
|
||
# remove xterm
|
||
services.xserver.excludePackages = [ pkgs.xterm ];
|
||
services.xserver.desktopManager.xterm.enable = false;
|
||
|
||
# Configure keymap in X11
|
||
services.xserver.xkb = {
|
||
layout = "us";
|
||
variant = "";
|
||
};
|
||
|
||
# Enable CUPS to print documents.
|
||
services.printing.enable = true;
|
||
|
||
# Enable sound with pipewire.
|
||
hardware.pulseaudio.enable = false;
|
||
security.rtkit.enable = true;
|
||
services.pipewire = {
|
||
enable = true;
|
||
alsa.enable = true;
|
||
alsa.support32Bit = true;
|
||
pulse.enable = true;
|
||
# If you want to use JACK applications, uncomment this
|
||
#jack.enable = true;
|
||
|
||
# use the example session manager (no others are packaged yet so this is enabled by default,
|
||
# no need to redefine it in your config for now)
|
||
#media-session.enable = true;
|
||
};
|
||
|
||
# Enable touchpad support (enabled default in most desktopManager).
|
||
# services.xserver.libinput.enable = true;
|
||
|
||
# Define a user account. Don't forget to set a password with ‘passwd’.
|
||
users.users.elias = {
|
||
isNormalUser = true;
|
||
description = "elias";
|
||
extraGroups = [ "networkmanager" "wheel" ];
|
||
packages = with pkgs; [
|
||
# thunderbird
|
||
];
|
||
};
|
||
|
||
# Enable automatic login for the user.
|
||
services.displayManager.autoLogin.enable = true;
|
||
services.displayManager.autoLogin.user = "elias";
|
||
|
||
# Workaround for GNOME autologin: https://github.com/NixOS/nixpkgs/issues/103746#issuecomment-945091229
|
||
systemd.services."getty@tty1".enable = false;
|
||
systemd.services."autovt@tty1".enable = false;
|
||
|
||
# Install firefox.
|
||
programs.firefox.enable = true;
|
||
|
||
# Allow unfree packages
|
||
nixpkgs.config.allowUnfree = true;
|
||
nixpkgs.config.nvidia.acceptLicense = true;
|
||
|
||
# List packages installed in system profile. To search, run:
|
||
# $ nix search wget
|
||
environment.systemPackages = with pkgs; [
|
||
# vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
|
||
wget
|
||
fastfetch
|
||
curl
|
||
keepassxc
|
||
git
|
||
htop
|
||
nextcloud-client
|
||
libreoffice-fresh
|
||
hunspell #dictionary for libreoffice
|
||
hunspellDicts.en_CA
|
||
hunspellDicts.en_US
|
||
];
|
||
|
||
# Fonts
|
||
fonts.packages = with pkgs; [
|
||
corefonts
|
||
vistafonts
|
||
noto-fonts
|
||
noto-fonts-cjk
|
||
noto-fonts-emoji
|
||
liberation_ttf
|
||
fira-code
|
||
fira-code-symbols
|
||
mplus-outline-fonts.githubRelease
|
||
dina-font
|
||
proggyfonts
|
||
];
|
||
|
||
fonts.fontDir.enable = true;
|
||
|
||
# Some programs need SUID wrappers, can be configured further or are
|
||
# started in user sessions.
|
||
# programs.mtr.enable = true;
|
||
# programs.gnupg.agent = {
|
||
# enable = true;
|
||
# enableSSHSupport = true;
|
||
# };
|
||
|
||
# List services that you want to enable:
|
||
|
||
# Enable the OpenSSH daemon.
|
||
services.openssh.enable = true;
|
||
|
||
# Tailscale
|
||
services.tailscale.enable = true;
|
||
|
||
# Flatpak
|
||
services.flatpak.enable = true;
|
||
|
||
# Open ports in the firewall.
|
||
networking.firewall.allowedTCPPorts = [ 22 ];
|
||
# networking.firewall.allowedUDPPorts = [ ... ];
|
||
# Or disable the firewall altogether.
|
||
# networking.firewall.enable = false;
|
||
|
||
# This value determines the NixOS release from which the default
|
||
# settings for stateful data, like file locations and database versions
|
||
# on your system were taken. It‘s perfectly fine and recommended to leave
|
||
# this value at the release version of the first install of this system.
|
||
# Before changing this value read the documentation for this option
|
||
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
|
||
system.stateVersion = "24.05"; # Did you read the comment?
|
||
|
||
}
|